Degraded server performance, increased lag issues
Incident Report for LSCRP
Resolved
This incident has been resolved.
Posted May 15, 2022 - 03:05 UTC
Update
Issues have reduced however the lag/texture loss is still happening for some users. Further updates will follow.
Posted May 14, 2022 - 23:51 UTC
Investigating
Players are experiencing lag issues and extreme texture loss.

Our development team has been notified, we apologise for any inconveniences caused.
Posted May 14, 2022 - 23:16 UTC
This incident affected: Servers (LSCRP Server 1 | RP).