Texture loss
Incident Report for LSCRP
Resolved
This incident has been resolved.
Posted Dec 27, 2022 - 03:16 UTC
Investigating
We are currently investigating players experiencing lag issues and extreme texture loss. Our development team has been notified.
Posted Dec 27, 2022 - 01:45 UTC
This incident affected: Servers (LSCRP Server 1 | RP).